Unable to Start Debugging on the Web Server. The Web Server is not Configured correctly.

Visual Studio Error

Visual Studio Build Error

Introduction

This blog is regarding one issue which happened couple of days back while building a demo app.

Background

One of the freshers in my company had this issue and I tried to resolve. The opportunity is huge, when you try to put yourself in their boot. They do crazy things and break the application. However, as my tech name is “BugTrapper“, so I started my research.

Problem

Then I found that the application is hosted in IIS with an IP in the binding.

iis-binding

Binding in IIS

Now, I wanted to check the Project Url in the Project Properties. This is what I saw.

project-properties

Project Properties

So, it’s obvious now. The problem is the URL mismatch.

Solution

I just updated the Project Url to the IP mentioned in IIS. Voila!!! All started working at the next moment.

Have you ever Faced This?

If yes, please comment below. Let’s discuss. Like and share if you want to save someone’s time. 🙂

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s